zammad.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. # --
  2. # RPM spec file for RHEL7 of the OTRS package
  3. # Copyright (C) 2001-2015 OTRS AG, http://otrs.com/
  4. # --
  5. # This software comes with ABSOLUTELY NO WARRANTY. For details, see
  6. # the enclosed file COPYING for license information (AGPL). If you
  7. # did not receive this file, see http://www.gnu.org/licenses/agpl.txt.
  8. # --
  9. #
  10. # please file bugfixes or comments on http://bugs.otrs.org
  11. #
  12. # --
  13. Summary: Zammad
  14. Name: zammad
  15. Version: 0.0
  16. License: GNU AFFERO GENERAL PUBLIC LICENSE Version 3, 19 November 2007
  17. Group: Applications/Mail
  18. Provides: zammad
  19. Requires: cronie httpd
  20. Autoreqprov: no
  21. Release: 01
  22. Source0: zammad-%{version}.tar.bz2
  23. BuildArch: noarch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-build
  25. %description
  26. <DESCRIPTION>
  27. %prep
  28. #%setup
  29. %build
  30. # copy config file
  31. %install
  32. # delete old RPM_BUILD_ROOT
  33. rm -rf $RPM_BUILD_ROOT
  34. # set DESTROOT
  35. export DESTROOT="opt/zammad/"
  36. # create RPM_BUILD_ROOT DESTROOT
  37. mkdir -p $RPM_BUILD_ROOT/$DESTROOT
  38. # copy files
  39. cd $RPM_BUILD_ROOT/$DESTROOT/../..
  40. pwd
  41. tar xfj ../../SOURCES/zammad-%{version}.tar.bz2 -C $DESTROOT
  42. #cp -Rv /opt/zammad $RPM_BUILD_ROOT/$DESTROOT
  43. # install init-Script
  44. #install -d -m 755 $RPM_BUILD_ROOT/etc/rc.d/init.d
  45. #install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
  46. # copy apache2-httpd.include.conf to /etc/httpd/conf.d/zzz_otrs.conf
  47. #install -m 644 scripts/apache2-httpd.include.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/zzz_otrs.conf
  48. # set permission
  49. export OTRSUSER=otrs
  50. #useradd $OTRSUSER || :
  51. #useradd apache || :
  52. #groupadd apache || :
  53. #$RPM_BUILD_ROOT/opt/otrs/bin/otrs.SetPermissions.pl --web-group=apache
  54. %pre
  55. # remember about the installed version
  56. #if test -e /opt/otrs/RELEASE; then
  57. # cat /opt/otrs/RELEASE|grep VERSION|sed 's/VERSION = //'|sed 's/ /-/g' > /tmp/otrs-old.tmp
  58. #fi
  59. # useradd
  60. export OTRSUSER=zammad
  61. echo -n "Check OTRS user ... "
  62. #if id $OTRSUSER >/dev/null 2>&1; then
  63. # echo "$OTRSUSER exists."
  64. # # update home dir
  65. # usermod -d /opt/otrs $OTRSUSER
  66. #else
  67. # useradd $OTRSUSER -d /opt/otrs/ -s /bin/bash -g zammad -c 'Zammad user' && echo "$OTRSUSER added."
  68. #fi
  69. %post
  70. # run OTRS rebuild config, delete cache, if the system was already in use (i.e. upgrade).
  71. export OTRSUSER=zammad
  72. %clean
  73. #rm -rf $RPM_BUILD_ROOT
  74. %files
  75. #%config(noreplace) /etc/sysconfig/otrs
  76. #%config /etc/httpd/conf.d/zzz_otrs.conf
  77. #/etc/rc.d/init.d/otrs
  78. /opt/zammad
  79. #<FILES>
  80. %changelog
  81. * Mon Dec 17 2012 - mb@otrs.com
  82. - Added dependencies to Digest::SHA, Net::LDAP and Crypt::SSLeay, available from base repositories.
  83. - Removed dependency on Time::HiRes in favor of perl-core package.