override.nix 549 B

12345678910111213141516171819202122232425262728
  1. pkgs: attrs: with pkgs; with attrs; rec {
  2. version = "2.1.28";
  3. src = fetchFromGitHub {
  4. owner = "cyrusimap";
  5. repo = "cyrus-sasl";
  6. rev = "cyrus-sasl-${version}";
  7. hash = "sha256-0AiHAdcOwF7OKpIZwJ7j9E/KTmtk9qmgpvl8vkFk0oE=";
  8. };
  9. nativeBuildInputs = [ autoreconfHook ];
  10. buildInputs = [
  11. openssl
  12. libxcrypt
  13. pam
  14. ];
  15. patches = [];
  16. configureFlags = [
  17. "--disable-shared"
  18. "--enable-static"
  19. "--with-saslauthd=/run/saslauthd"
  20. "--with-devrandom=/dev/urandom"
  21. "--with-openssl=${openssl.dev}"
  22. ];
  23. }