override.nix 626 B

12345678910111213141516171819202122232425262728
  1. pkgs: attrs: with pkgs; with attrs; rec {
  2. version = "1.1.1t";
  3. versionWithUnderscores = "${lib.replaceStrings ["."] ["_"] version}";
  4. src = fetchFromGitHub {
  5. owner = "openssl";
  6. repo = "openssl";
  7. rev = "OpenSSL_${versionWithUnderscores}";
  8. hash = "sha256-gI2+Vm67j1+xLvzBb+DF0YFTOHW7myotRsXRzluzSLY=";
  9. };
  10. patches = [
  11. ./dso-none.patch
  12. ];
  13. buildInputs = [ zlib ];
  14. configureFlags = [
  15. # "shared" builds both shared and static libraries
  16. "shared"
  17. "--libdir=lib"
  18. "--openssldir=etc/ssl"
  19. "enable-ec_nistp_64_gcc_128"
  20. "no-dynamic-engine"
  21. "no-tests"
  22. "zlib"
  23. ];
  24. }