override.nix 627 B

1234567891011121314151617181920212223242526272829
  1. pkgs: attrs: with pkgs; with attrs; rec {
  2. version = "2024-07-02";
  3. src = fetchFromGitHub {
  4. owner = "google";
  5. repo = "re2";
  6. rev = "${version}";
  7. hash = "sha256-IeANwJlJl45yf8iu/AZNDoiyIvTCZIeK1b74sdCfAIc=";
  8. };
  9. buildInputs = [
  10. abseil-cpp
  11. gbenchmark
  12. gtest
  13. ];
  14. # revert weird macOS-specific setting from nixpkgs upstream
  15. cmakeBuildDir = "build";
  16. cmakeFlags = [
  17. "-DBUILD_SHARED_LIBS=ON"
  18. "-DRE2_BUILD_TESTING=ON"
  19. # re2 (as of 2023-06-02) unconditionally targets c++14,
  20. # we patch it in order to make it linkable against abseil-cpp
  21. # "-DCMAKE_CXX_STANDARD=17"
  22. ];
  23. }