override.nix 684 B

1234567891011121314151617181920212223242526
  1. pkgs: attrs: with pkgs; with attrs; rec {
  2. version = "16.0.6";
  3. src = fetchFromGitHub {
  4. owner = "llvm";
  5. repo = "llvm-project";
  6. rev = "llvmorg-${version}";
  7. hash = "sha256-fspqSReX+VD+Nl/Cfq+tDcdPtnQPV1IRopNDfd5VtUs=";
  8. };
  9. patches = [
  10. # https://reviews.llvm.org/D132298, Allow building libcxxabi alone
  11. (fetchpatch {
  12. url = "https://github.com/llvm/llvm-project/commit/e6a0800532bb409f6d1c62f3698bdd6994a877dc.patch";
  13. sha256 = "1xyjd56m4pfwq8p3xh6i8lhkk9kq15jaml7qbhxdf87z4jjkk63a";
  14. stripLen = 1;
  15. })
  16. ];
  17. NIX_CFLAGS_COMPILE = [
  18. # See DTCC-589 for the details
  19. "-fno-integrated-cc1"
  20. ];
  21. sourceRoot = "source/libcxxabi";
  22. }