requirements-dev.txt 965 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. --index-url https://pypi.devinfra.sentry.io/simple
  2. covdefaults>=2.3.0
  3. docker>=3.7.0,<3.8.0
  4. freezegun>=1.1.0
  5. honcho>=1.1.0
  6. openapi-core>=0.14.2
  7. pytest>=7.2.1
  8. pytest-cov>=4.0.0
  9. pytest-django>=4.4.0
  10. pytest-fail-slow>=0.3.0
  11. pytest-rerunfailures>=11
  12. pytest-sentry>=0.1.11
  13. pytest-xdist>=3
  14. responses>=0.23.1
  15. sentry-cli>=2.16.0
  16. # pre-commit dependencies
  17. pre-commit>=3.3
  18. black>=22.10.0
  19. flake8>=6
  20. flake8-bugbear>=22.10
  21. pyupgrade>=3.2.3
  22. isort>=5.10.1
  23. # For tools/. To be moved into redistributable dev environments.
  24. # note: wheel is pulled in by pip-tools
  25. pip-tools>=6.7.0
  26. packaging>=21.3
  27. # for type checking
  28. django-stubs
  29. djangorestframework-stubs
  30. lxml-stubs
  31. msgpack-types>=0.2.0
  32. mypy>=1.4.1
  33. types-beautifulsoup4
  34. types-cachetools
  35. types-croniter
  36. types-freezegun
  37. types-jsonschema
  38. types-oauthlib
  39. types-parsimonious
  40. types-pillow
  41. types-protobuf
  42. types-psycopg2
  43. types-python-dateutil
  44. types-pytz
  45. types-pyyaml
  46. types-redis
  47. types-requests
  48. types-setuptools
  49. types-simplejson>=3.17.7.2