mc.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234
  1. # Note that this is NOT a relocatable package
  2. %define ver 4.5.2
  3. %define rel SNAP
  4. %define prefix /usr
  5. Summary: Midnight Commander visual shell
  6. Name: mc
  7. Version: %ver
  8. Release: %rel
  9. Copyright: GPL
  10. Group: Shells
  11. Source0: ftp://ftp.nuclecu.unam.mx/linux/local/devel/mc-%{PACKAGE_VERSION}.tar.gz
  12. URL: http://www.gnome.org/mc/
  13. BuildRoot: /tmp/mc-%{PACKAGE_VERSION}-root
  14. Requires: pam >= 0.59
  15. Prereq: /sbin/chkconfig
  16. %description
  17. Midnight Commander is a visual shell much like a file manager, only with way
  18. more features. It is text mode, but also includes mouse support if you are
  19. running GPM. Its coolest feature is the ability to ftp, view tar, zip
  20. files, and poke into RPMs for specific files. :-)
  21. %package -n gmc
  22. Summary: Midnight Commander visual shell (GNOME version)
  23. Requires: mc >= 4.1.31
  24. Group: X11/Shells
  25. %description -n gmc
  26. Midnight Commander is a visual shell much like a file manager, only with
  27. way more features. This is the GNOME version. It's coolest feature is the
  28. ability to ftp, view tar, zip files and poke into RPMs for specific files.
  29. The GNOME version of Midnight Commander is not yet finished though. :-(
  30. %package -n mcserv
  31. Summary: Midnight Commander file server
  32. Group: X11/Shells
  33. Requires: portmap
  34. %description -n mcserv
  35. mcserv is the server program for the Midnight Commander networking file
  36. system. It provides access to the host file system to clients running the
  37. Midnight file system (currently, only the Midnight Commander file manager).
  38. %prep
  39. %setup
  40. %build
  41. CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./autogen.sh \
  42. --prefix=%{prefix} \
  43. --with-gnome \
  44. --without-debug
  45. if [ "$SMP" != "" ]; then
  46. (make "MAKE=make -k -j $SMP"; exit 0)
  47. make
  48. else
  49. make
  50. fi
  51. %install
  52. rm -rf $RPM_BUILD_ROOT
  53. install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,profile.d,X11/wmconfig}
  54. make prefix=$RPM_BUILD_ROOT%{prefix} install
  55. (cd icons; make prefix=$RPM_BUILD_ROOT%{prefix} install_icons)
  56. install lib/mcserv.init $RPM_BUILD_ROOT/etc/rc.d/init.d/mcserv
  57. install lib/mcserv.pamd $RPM_BUILD_ROOT/etc/pam.d/mcserv
  58. install lib/{mc.sh,mc.csh} $RPM_BUILD_ROOT/etc/profile.d
  59. # clean up this setuid problem for now
  60. chmod 755 $RPM_BUILD_ROOT/usr/lib/mc/bin/cons.saver
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %post -n mcserv
  64. /sbin/chkconfig --add mcserv
  65. %postun -n mcserv
  66. /sbin/chkconfig --del mcserv
  67. %files
  68. %defattr(-, root, root)
  69. %doc FAQ COPYING NEWS README
  70. /usr/bin/mc
  71. /usr/bin/mcedit
  72. /usr/bin/mcmfmt
  73. /usr/lib/mc/mc.ext
  74. /usr/lib/mc/mc.hint
  75. /usr/lib/mc/mc.hlp
  76. /usr/lib/mc/mc.lib
  77. /usr/lib/mc/mc.menu
  78. /usr/lib/mc/bin/cons.saver
  79. /usr/lib/mc/extfs/*
  80. /usr/man/man1/*
  81. %config /etc/profile.d/*
  82. %dir /usr/lib/mc
  83. %dir /usr/lib/mc/bin
  84. %dir /usr/lib/mc/extfs
  85. %files -n mcserv
  86. %defattr(-, root, root)
  87. %config /etc/pam.d/mcserv
  88. %config /etc/rc.d/init.d/mcserv
  89. %attr(-, root, man) /usr/man/man8/mcserv.8
  90. /usr/bin/mcserv
  91. %files -n gmc
  92. %defattr(-, root, root)
  93. /usr/bin/gmc
  94. /usr/lib/mc/layout
  95. /usr/share/icons/mc/*
  96. %changelog
  97. * Thu Aug 20 1998 Michael Fulbright <msf@redhat.com>
  98. - rebuilt against gnome-libs 0.27 and gtk+-1.1
  99. * Thu Jul 09 1998 Michael Fulbright <msf@redhat.com>
  100. - made cons.saver not setuid
  101. * Sun Apr 19 1998 Marc Ewing <marc@redhat.com>
  102. - removed tkmc
  103. * Wed Apr 8 1998 Marc Ewing <marc@redhat.com>
  104. - add /usr/lib/mc/layout to gmc
  105. * Tue Dec 23 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  106. - added --without-debug to configure,
  107. - modification in %build and %install and cosmetic modification in packages
  108. headers,
  109. - added %%{PACKAGE_VERSION} macro to Buildroot,
  110. - removed "rm -rf $RPM_BUILD_ROOT" from %prep.
  111. - removed Packager field.
  112. * Thu Dec 18 1997 Michele Marziani <marziani@fe.infn.it>
  113. - Merged spec file with that from RedHat-5.0 distribution
  114. (now a Hurricane-based distribution is needed)
  115. - Added patch for RPM script (didn't always work with rpm-2.4.10)
  116. - Corrected patch for mcserv init file (chkconfig init levels)
  117. - Added more documentation files on termcap, terminfo, xterm
  118. * Thu Oct 30 1997 Michael K. Johnson <johnsonm@redhat.com>
  119. - Added dependency on portmap
  120. * Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
  121. - fixed spec file.
  122. - Updated to 4.1.8
  123. * Sun Oct 26 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  124. - updated to 4.1.6
  125. - added %attr macros in %files,
  126. - a few simplification in %install,
  127. - removed glibc patch,
  128. - fixed installing /etc/X11/wmconfig/tkmc.
  129. * Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
  130. - updated to 4.1.5
  131. - added wmconfig
  132. * Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
  133. - chkconfig is for mcserv package, not mc one
  134. * Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
  135. - patched init script for chkconfig
  136. - don't turn on the service by default
  137. * Fri Oct 10 1997 Michael K. Johnson <johnsonm@redhat.com>
  138. - Converted to new PAM conventions.
  139. - Updated to 4.1.3
  140. - No longer needs glibc patch.
  141. * Thu May 22 1997 Michele Marziani <marziani@fe.infn.it>
  142. - added support for mc alias in /etc/profile.d/mc.csh (for csh and tcsh)
  143. - lowered number of SysV init scripts in /etc/rc.d/rc[0,1,6].d
  144. (mcserv needs to be killed before inet)
  145. - removed all references to $RPM_SOURCE_DIR
  146. - restored $RPM_OPT_FLAGS when compiling
  147. - minor cleanup of spec file: redundant directives and comments removed
  148. * Sun May 18 1997 Michele Marziani <marziani@fe.infn.it>
  149. - removed all references to non-existent mc.rpmfs
  150. - added mcedit.1 to the %files section
  151. - reverted to un-gzipped man pages (RedHat style)
  152. - removed double install line for mcserv.pamd
  153. * Tue May 13 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  154. - added new rpmfs script,
  155. - removed mcfn_install from mc (adding mc() to bash enviroment is in
  156. /etc/profile.d/mc.sh),
  157. - /etc/profile.d/mc.sh changed to %config,
  158. - removed /usr/lib/mc/bin/create_vcs,
  159. - removed /usr/lib/mc/term.
  160. * Wed May 9 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  161. - changed source url,
  162. - fixed link mcedit to mc,
  163. * Tue May 7 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  164. - new version 3.5.27,
  165. - %dir /usr/lib/mc/icons and icons removed from tkmc,
  166. - added commented xmc part.
  167. * Tue Apr 22 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  168. - FIX spec:
  169. - added URL field,
  170. - in mc added missing /usr/lib/mc/mc.ext, /usr/lib/mc/mc.hint,
  171. /usr/lib/mc/mc.hlp, /usr/lib/mc/mc.lib, /usr/lib/mc/mc.menu.
  172. * Fri Apr 18 1997 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
  173. - added making packages: tkmc, mcserv (xmc not work yet),
  174. - gziped man pages,
  175. - added /etc/pamd.d/mcserv PAM config file.
  176. - added instaling icons,
  177. - added /etc/profile.d/mc.sh,
  178. - in %doc added NEWS README,
  179. - removed /usr/lib/mc/FAQ,
  180. - added mcserv.init script for mcserv (start/stop on level 86).