rules 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. #!/usr/bin/make -f
  2. PACKAGE=isync
  3. CFLAGS = -Wall -g
  4. ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
  5. CFLAGS += -O0
  6. else
  7. CFLAGS += -O2
  8. endif
  9. DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  10. DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  11. build: build-stamp
  12. build-stamp: patch-stamp
  13. dh_testdir
  14. ./configure --disable-maintainer-mode --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man
  15. $(MAKE) CFLAGS="$(CFLAGS)"
  16. touch build-stamp
  17. clean: clean1 unpatch
  18. clean1:
  19. dh_testdir
  20. dh_testroot
  21. rm -f build-stamp
  22. -$(MAKE) distclean
  23. dh_clean Makefile config.log config.status
  24. install: build
  25. dh_testdir
  26. dh_testroot
  27. dh_clean -k
  28. dh_installdirs usr/bin usr/share/man/man1
  29. $(MAKE) DESTDIR=$(CURDIR)/debian/isync install
  30. binary-indep: build install
  31. binary-arch: build install
  32. dh_testdir
  33. dh_testroot
  34. dh_installchangelogs ChangeLog
  35. dh_installdocs AUTHORS NEWS README TODO
  36. dh_installexamples isyncrc.sample
  37. dh_installman
  38. dh_installdebconf
  39. dh_strip
  40. dh_compress
  41. dh_fixperms
  42. dh_installdeb
  43. dh_shlibdeps
  44. dh_gencontrol
  45. dh_md5sums
  46. dh_builddeb
  47. binary: binary-indep binary-arch
  48. .PHONY: build clean binary-indep binary-arch binary install clean1
  49. include /usr/share/dpatch/dpatch.make