1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859 |
- #!/usr/bin/make -f
- PACKAGE=isync
- CFLAGS = -Wall -g
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- else
- CFLAGS += -O2
- endif
- DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
- DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
- build: build-stamp
- build-stamp: patch-stamp
- dh_testdir
- ./configure --disable-maintainer-mode --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man
- $(MAKE) CFLAGS="$(CFLAGS)"
- touch build-stamp
- clean: clean1 unpatch
- clean1:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- -$(MAKE) distclean
- dh_clean Makefile config.log config.status
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs usr/bin usr/share/man/man1
- $(MAKE) DESTDIR=$(CURDIR)/debian/isync install
- binary-indep: build install
- binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs AUTHORS NEWS README TODO
- dh_installexamples isyncrc.sample
- dh_installman
- dh_installdebconf
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install clean1
- include /usr/share/dpatch/dpatch.make
|